• SyncTERM copy/paste

    From MeaTLoTioN@1337:1/101 to All on Fri Feb 26 00:35:21 2021
    Hey guys, I thought I would let you into something I just found out... and it should work in ALL versions of SyncTERM. Bare with me here, as I will try and explain what is happening and how I just figured how to work around it.

    Bask story;
    2 days ago, my PC (not my hypervisor this time) had a catastrophic issue after trying to upgrade from Ubuntu 18.04 to 20.04. I had a gut feeling it would go bad, but not to the extent it did, but that is for another day and another story, but TLDR; I had to wipe and start again, with Ubuntu 20.04. I got it all working pretty quick.

    Issue;
    SyncTERM used to be able to copy/paste for me fine, but I used to hear a lot from others that it doesn't for them, on Windows, Mac and also Linux, but it worked for me so I didn't really know where to start investigating.

    Since the new install of Ubuntu 20.04, I downloaded the latest version of SyncTERM, built and ran it and just today when trying to copy text from a BBS page realised that I couldn't! So this is what it feels like to be everyone else, huh? Crap. So I remembered that I used to use an older build so I grabbed v1.1 and built that but no dice. Okay so now I actually see what everyone else does, and I don't like it.

    Investigation;
    SyncTERM is a neat bit of kit, and can do a multitude of things over and above most any other terminal you could throw a stick at, but to lose something so useful and honestly so normal is like losing a limb (bad comparison, but kinda is).

    I spent half hour or so going through different options, seeing if there is anything that looks like it might be related, but nothing jumps out at me, then I notice when I'm not connected to a BBS, just viewing the dialing directory I can still use the mouse and select text which automatically puts it into the clipboard. Interesting, huh... I bet that's the same for Windows and Mac too, feel free to give me your experiences here.

    It then occurred to me that perhaps it's not actually SyncTERM at all that is preventing the copy/paste but something to do with what it connects to and how it connects. As you prolly know, Mystic and Synchronet both can handle the mouse, and now by default they will grab the mouse ready for event handling which I noticed by chance when I run the mouse over my SyncTERM screen when it's a) not connected to a BBS I get a "text" cursor, i.e. it looks like a capitol I just with slightly longer horizontals top and bottom, but when I run the mouse over the terminal when connected to a BBS, I get instead the normal arrow pointer.

    I then started to see if when connected there is anything I can do in SyncTERM to stop the mouse from being controlled, and sure enough hitting ALT+B (to access the scroll back buffer) the mouse cursor changes to the text cursor. From there I can select text like you would in any text editor. Once you select some text, and let go of the mouse button it's in the clipboard.

    Leaving the scroll back buffer by hitting escape now brings me back to normal mode and the mouse cursor is back to the arrow pointer. I used to be able to just hit the middle mouse button to paste however this still doesn't work but I remember an old trick that I used to use back in Windows 3.1 and that is to press SHIFT+INSERT to paste as sometimes CTRL+V wouldn't work, well guess what, I pressed SHIFT+INSERT and it pastes my copied text perfectly.

    Summary;
    I think I have figured out how to copy and paste text in SyncTERM using a different method, the next thing I want to figure out is how to stop the BBS taking over the mouse without using the scroll back buffer to intercept it. It used to work, just not since I reinstalled my PC.

    Hopefully your mileage won't vary on this, it will work just like it does for me, I am eager to hear how y'all get on with this.


    Hopefully I haven't bored y'all, and that you found this information interesting and useful.

    ---
    |14Best regards,
    |11Ch|03rist|11ia|15n |11a|03ka |11Me|03aTLoT|11io|15N

    |07── |08[|10eml|08] |15ml@erb.pw |07── |08[|10web|08] |15www.erb.pw |07───┐ |07── |08[|09fsx|08] |1521:1/158 |07── |08[|11tqw|08] |151337:1/101 |07┬──┘ |07── |08[|12rtn|08] |1580:774/81 |07─┬ |08[|14fdn|08] |152:250/5 |07───┘
    |07── |08[|10ark|08] |1510:104/2 |07─┘

    --- Mystic BBS v1.12 A47 2020/12/04 (Linux/64)
    * Origin: thE qUAntUm wOrmhOlE, rAmsgAtE, uK. bbs.erb.pw (1337:1/101)
  • From paulie420@1337:3/129 to MeaTLoTioN on Fri Feb 26 19:18:41 2021
    it's in the clipboard

    SHIFT+INSERT has copied the text I selected while in Alt-B scrollback mode... I still can't 'copy' text while in normal mode... but you're right:

    it's in the clipboard


    SHIFT+INSERT does print the copied text.... good job MeaT... I wonder if we can figure out how the heck I can get FULL copy/paste going again. It was neat to see you think thru this, and how I didn't... but still, its not 'working'. Furthermore, I was always on some Ubuntu 20.04+ version... and I can tell you its the same under Manjaro/ARCH as I've used both. Funny, too, because now that I think about it, when I was using KDE Neon I *could* copy/paste like normal.

    Where it hasn't worked, for me:
    KUBUNTU 20.04
    Ubuntu 20.04
    Manjaro current
    ARCH current

    But KDE Neon, it DID work.



    |07p|15AULIE|1142|07o
    |08.........

    --- Mystic BBS v1.12 A47 2021/01/26 (Raspberry Pi/32)
    * Origin: 2o fOr beeRS bbs>>>20ForBeers.com:1337 (1337:3/129)