• Dial-up connection problems

    From Neko@VERT/MIYANET to All on Tue Aug 31 23:48:47 2021
    Hello,
    Recently I have bought a 56 kbps faxmodem to connect with my BBS and try how people used to contact each other before TCP/IP and DSL (my first contact with computers was when DSL began making dial-up obsolete). As I do not own a landline, I have bought a cellular fixed terminal too.
    However, before connecting it to my BBS I wanted to make sure the modem can connect with anyone. At first, after charging my SIM card with some money and turning on the terminal, I connected the modem to my server. Then, I installed RS232-USB UART driver and added a modem through Windows "Phone and modem" menu - it got detected automatically without even opening the wizard. After that, I started PUTTY in order to dial and receive test calls using AT commands. AT returned OK, so the modem was connected. ATDT to my daily cellular number - it dialed with loud internal speaker noise, so I had to mute that with ATL0M0. Picking up a call in opposite direction - ATA works perfectly dropping to NO CARRIER quickly after as no commands were received. I thought it was fine.

    Problems began when I tried to dial a BBS. I tried HyperTerminal as it was already installed on my server used for BBSing, trying a connection with one of those rare European BBSes (to avoid draining my pre-paid account as I am not living in the USA). It dialed... and threw "No answer" message.
    Then, I tried sending a fax to Fax Toy website, setting up the modem in fax mode and using fax capabilities of Windows. A simple test page, sending it to given phone number and after ca. 3 mins of waiting, pulsing of SD and CTS diodes, got an error. Simply, an error - no code, nothing. Tried calling the same number using my main mobile phone - fax tones are heard. After that I tried again with dialing myself (now in fax mode) to check if the modem can call - it could.

    The modem is 3com by USRobotics Sportster V.90 MessagePlus, connected to Huawei B310s-22 cellular modem as a substitute of a landline (firmware locked to cellular terminal mode - yes, it has RJ-11) and to the server via RS232-USB UART as it does not have RS232 port. I am running it under Windows Server 2003 R2 (on a virtual machine, if it matters).

    I have already tried playing sounds of Bell 103 transmissions or V.32/V.34 handshakes to my personal phone's microphone when dialing to the modem - this way I got the sweet CONNECT information and a few garbage characters before NO CARRIER (or simply garbage characters and quicker NO CARRIER in case of Bell 103).
    Another weird thing I have noticed is these longer tones of dial-up handshake attempt fade after a few seconds. They appear again for a short moment after making some noise to the microphone or sending DTMF (pressing keypad buttons).

    Do you have any idea how to cope with such an issue and CONNECT to others as the modem should?

    Thank you in advance, Neko

    ---
    ■ Synchronet ■ MIYANET - miya-net.tk:(22|23|80) | +48 782 287 282 (GSM)